0

And are the problem's root causes the same? I've done a decent amount of research but the methods I've tried so far have failed. Backup and Migrate gave me this error when I imported the database only:

Notice: Undefined index: highlighted in include() (line 126 of /home/drupal7/public_html/drupal-test-site/modules/system/page.tpl.php).
Notice: Undefined index: sidebar_second in include() (line 144 of /home/drupal7/public_html/drupal-test-site/modules/system/page.tpl.php).
Notice: Undefined index: enabled in system_themes_page() (line 239 of /home/drupal7/public_html/drupal-test-site/modules/system/system.admin.inc).
Warning: uasort() expects parameter 1 to be array, null given in system_themes_page() (line 245 of /home/drupal7/public_html/drupal-test-site/modules/system/system.admin.inc).
Notice: Undefined index: adminimal in theme_get_setting() (line 1439 of /home/drupal7/public_html/drupal-test-site/includes/theme.inc).
Notice: Trying to get property of non-object in theme_get_setting() (line 1476 of /home/drupal7/public_html/drupal-test-site/includes/theme.inc).
Notice: Trying to get property of non-object in theme_get_setting() (line 1486 of /home/drupal7/public_html/drupal-test-site/includes/theme.inc).

It gave me this when I imported the full site:

Fatal error: Call to undefined function file_directory_path() in /home/drupal7/public_html/drupal-test-site/sites/all/modules/backup_migrate/includes/sources.archivesource.inc on line 211

Line 211 being

  // Move the files from the temp directory.
  if ($filepath && file_exists($filepath)) {
    _backup_migrate_move_files($filepath, file_directory_path());
  }
  else {
    _backup_migrate_message('Files were not restored because the archive did not seem to contain a files directory or was in a format that Backup and Migrate couldn\'t read', array(), 'warning');
  }

(I didn't get that _backup_migrate_message)

Doing the MySQL import manually gave me

Error
SQL query:

--
-- Dumping data for table `actions`
--

INSERT INTO `actions` (`aid`, `type`, `callback`, `parameters`, `label`) VALUES
('comment_publish_action', 'comment', 'comment_publish_action', '', 'Publish comment'),
('comment_save_action', 'comment', 'comment_save_action', '', 'Save comment'),
('comment_unpublish_action', 'comment', 'comment_unpublish_action', '', 'Unpublish comment'),
('node_make_sticky_action', 'node', 'node_make_sticky_action', '', 'Make content sticky'),
('node_make_unsticky_action', 'node', 'node_make_unsticky_action', '', 'Make content unsticky'),
('node_promote_action', 'node', 'node_promote_action', '', 'Promote content to front page'),
('node_publish_action', 'node', 'node_publish_action', '', 'Publish content'),
('node_save_action', 'node', 'node_save_action', '', 'Save content'),
('node_unpromote_action', 'node', 'node_unpromote_action', '', 'Remove content from front page'),
('node_unpublish_action', 'node', 'node_unpublish_action', '', 'Unpublish content'),
([...]

MySQL said:

#1062 - Duplicate entry 'comment_publish_action' for key 'PRIMARY'

I tried importing the database into a fresh one before installing but that gives me

Drupal already installed

To start over, you must empty your existing database.
To install to a different database, edit the appropriate settings.php file in the sites folder.
To upgrade an existing installation, proceed to the update script.
View your existing site.

I'm importing from a Windows 8.1 Bitnami install to a shared hosting account. I'm willing to migrate the theme files manually, all I care about automating is the modules and their configuration as configuring them takes a lot of time.

  • What is your Drupal version and Backup and Migrate version? – Kari Kääriäinen Jun 19 '15 at 22:57
  • @KariKääriäinen Both up to date, 7.38 and 7.x-3.1. I just tried it again on a fresh install, this time uploading the backup to the directory via ftp and using restore from a saved backup. Still getting the line 211 error. – James Jun 19 '15 at 23:46
  • Are you able to run a fresh Drupal in your destination without any errors? – Kari Kääriäinen Jun 20 '15 at 6:11
  • Possible duplicate of Why does nothing change when I attempt to restore a backup? – kenorb Mar 24 '16 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.