1

I have a Views block which uses FlexSlider Views Slideshow as the format. The fields which supply the captions have translations but only the default (English) versions are displayed with the FlexSlider Views Slideshow format. Example of the Views block using FlexSlider Views Slideshow can be seen here.

I have a Views page as part of the same view which uses unformatted list as the format. This handles the translated as expected. Example of the Views page is here.

The captions are from the title field of the content type which use the Titles module so they can be translated.

Other modules in the mix are i18n, i18n_block, i18n_field, i18n_views which enable the content to be translated in the first place.

So, my question is: How to get the FlexSlider Views Slideshow to display translated content?

I've checked the Field Language setting is Current User's Language in the View.

I've checked the Make this block translatable option is checked in the block's configuration.

I've checked the Language Detection Settings are ordered; URL, User, Default

I've cleared all the caches.

I appreciate your suggestions.

0

Your problem might be because of the "language detection" configuration.

So check this configuration via Configuration -> Languages -> detection and selection: the order should be 'URL, Default, User', and not something like 'Default, URL, User'.

  • Reviewed my Detection and Selection settings which were ordered; URL, User, Default. Reordering to; URL, Default, User did not change the Views block's output. I appreciate the suggestion. – Andrew Jun 23 '15 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.