Using Search_api, search_api_db and facet_api.

Ive created a view display using 'Facet Block'.

Ive set the facet field to the one I want to use. The facet configuration of this field has no listing limits.

ive set the view setting's 'pagination' to display all items.

When I look at the rendered block, it only shows 10 items.

Does anyone ever face this kind of problem ?

Is there an hard-coded limit ?

  • Using hte debug template setting, or preprocess_block function, I can see that the block is populated with 10 items, no more.
    – Math666
    Commented Jun 26, 2015 at 8:14
  • I don't know why but facets are limited at some point
    – Math666
    Commented Jun 26, 2015 at 8:19
  • any update on this issue?
    – milkovsky
    Commented Aug 16, 2017 at 13:47

1 Answer 1


You can manually edit this limit in the search_api_views module source file.

You find this here in the commerce kickstart bundle:


Then you correct the limit of 10 on line 167 of display_facet_block.inc

$limit = empty($this->view->query->pager->options['items_per_page']) ? 100

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.