1

I have a production apache server (which I have limited capabilities to fix) and I'm struggling to install drush on it. It's Win 2008 R2 server, the php is 5.3.8 and the Mysql server is 5.1.60. Clearly this has been running for years.

Because of the PHP version I cannot use Composer. I've downloaded the windrush folder from the drupal github page (7.0). I've set the Windows PATH to this folder and at least Windows CMD recognizes drush.

But when I attempt to run a command, (the prime mover for wanting to install drush so I can understand the errors in installing a custom module) it bails with the error in the subject line.

drush en mycustommodule

Googling for this command in context suggests that the PDO, Mysql extensions are not enabled in php.ini. Since this server has been running drupal for years, I can confirm they are enabled.

How else to troubleshoot what's breaking? The error is coming from the drupal's includes/database/mysql/database.inc

Thanks for your help to point me in the right direction, sam

  • It sounds like PDO isn't enabled for your CLI version of PHP - run php -i | grep pdo_mysql to confirm. If you don't see a list of extensions that includes pdo_mysql, you need to add the extension to your CLI version's php.ini – Clive Jun 23 '15 at 14:04
  • Yes, that sounds plausible. However, running the command yields: pdo_mysql – sam452 Jun 23 '15 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.