1

If I Download a css background image of my site, changing it with GIMP (or MS paint for that matter) and re upload it, nothing will happen. Moreover, even after I delete the file from the server, the image stays online... clicking "Flush all caches" nothing happens... I also note that the image basically stays the same --- Same filename and file extension, so it's extremely wired. What would you suggest of checking?

What I already tried and didn't help:

  • Turning off server external caching tool (for both static and dynamic cache).
  • Turning off AdvAgg from config/development/performance/advagg (Unchecked "Enable...")
  • Turning off Drupal's internal cache system.

Update: Working answer found... See below for the answer with green checkmark.

  • Are you using the color module or AdaptiveTheme? Also what version of AdvAgg do you have? – mikeytown2 Jun 24 '15 at 0:35
  • 1
    Try flushing your browser cache – Geoff Jun 24 '15 at 0:55
  • I use the color module but I don't use Adaptive theme. My Advagg version is 2.11.7. Clicking ctrl+F5 or total clear of browser's cache doesn't help. – JohnDoea Jun 24 '15 at 1:59
  • are you positive you are replacing the file correctly? try a different browser. – Geoff Jun 24 '15 at 5:08
  • Tried Chrome - No change. I've tried it with 3 files already (replaced them as described above), but it keeps render the old files --- unless I change the filename and the CSS path respectively. – JohnDoea Jun 24 '15 at 5:24
1

Since all caching aren't able to fix, let's try narrowing down the issue.

First, try to delete the image from your theme. Flush all caches and see if the background image is still there. If it is, open your browser development tool and check the background image URL and try opening it in a new tab, check the URL of the image and follow it in your server's directory if it really still exists.

Second, try restarting the server or any related running services you have in your server.

Hope this can at least give an idea on where to find what's causing the issue.

0
+150

Go to your theme's settings page and save it. The color module can cause issues like you're describing. AdvAgg tries really hard to detect this but it can't catch every use case. This is an issue with core that AdvAgg fixes 95% of the time.

  • Saved the theme's settings, flushed all caches right afterwards, and clicked ctrl+f5, but I give my word - nothing has changed... I've never encountered this problem before. Until last week I had no caching in my website - Not the Drupal internal cache of any kind, and not any external caching tool... Is there anything I should check in Advagg that might help? – JohnDoea Jun 24 '15 at 6:51
  • Notification: totally uninstalled color module, nothing's changed... – JohnDoea Jun 24 '15 at 17:32
  • Well it was worth a shot. I'm out of ideas. – mikeytown2 Jun 24 '15 at 17:57
  • One last notification (?)... Even deleting the file from mytheme/images/, flushing all caches, and clicking ctrl+f5 in two browsers didn't change the render! It's most probably the external caching tool on Cpanel... – JohnDoea Jun 24 '15 at 18:46
0

This is a caching issue, and there are different places this could happen depending on your set up:

  • Proxy (like Varnish)
  • Webserver (like apache or nginx)
  • browser

Webservers usually don't cache resources, I've seen some short lived caches on nginx - like 5-10 secs.

Most likely the caching is going on in a proxy or your browser. You would probably know about the proxy issue if you did use a proxy, so my best guess, is that your browser is caching the image.

To test if the issue is a caching issue, you can try to view the image from the url used in the CSS and you should see the same image as on the webpage. You can then try to alter the URL by adding a GET param.

If the url to the image is: http://example.com/image.png, you can change the url to http://example.com/image.png?test=1

Since the url is now completely different, the browser (and proxy) wouldn't have stored a cache for this, and you should see the image that you just uploaded. If that is the case, it proves you need to clear caches.

When doing development, it can be an advantedge to turn off browser cache completely to avoid issues like this. There are many extensions for all browsers that can help you with this, if it's not built in the browser.

  • Spoke with my servers support guys - Told them I totally disabled the Drupal cache, External caching tool (Supercacher), Mechmade, and than flushed all drupal cache + browser cache and nothing helped, so one of them flushed ("purged") the Cloudflare cdn cache and suddenly the image no longer appeard in my end, but, this is still problematic because it never was that way that a manual flushing of the cdn's cache is needed, So I told them that and they told me "Clear" your DNS cache from Windows CLI (didn't help), and contact your ISP... Purging CDN cache each time is not natural I guess... – JohnDoea Jun 28 '15 at 0:39
0

I highly recommend you to turn off AdvAgg by disabling it on your modules page and go from there.

Drupal has so many caching tools that you have to run down the trail module by module

If you use OpCache or Memchache as well you should at least flush them once as well before you turn back on any caching related modules.

Memcache often is the issue if it doesn't get flushed

See here to learn how to flush memcache from your console

By the Way if you develop a mobile site you should have a look in to

This is my combination of trust to handle images on mobile sites

0

The problem is apparently CDN based. I use the free version of the Cloudflare CDN service, and after purging it's cache, the deleted image no longer appeared on-line at site... I've tried to repeat the procedure to vindicate that indeed it was the CDN service so I reuploaded the image with some color changes and another file name, and again, after I deleted it, it kept appearing on-line at the site, but disappeared only after purging the CDN cache (but not any other type of cache) via the Cpanel based Cloudflare managing area.

So, Better try to purge it if you come across this problem, or purge and turn off the CDN for a while (especially if it won't damage your loading times and on-page optimization scores). Maybe dev mode is an alternative for turning it off completely - didn't try that option. Ben.

enter image description here

0

I get this randomly and also the same thing with favicons. I wasn't running a CDN and never solved it, instead I just started incrementing the file names one by one to avoid the issue completely.

It's not a clever solution, but if you're in a rush it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.