1

I created this website http://peace-in-the-city.be/en/book-now and on that page you will see I used a Calendar to show the availability of the apartment. ( http://drupal.org/project/availability_calendars )

I tried to let the calendar start on Monday. I googled for the solutions and did change my regional settings local to start of the week to Monday. It worked after that for a couple days. But for some reasons it went back to Saturday. Changing the regional setting has no effect anymore now.

At this point, I'm clueless... Any tips, links and ofcourse working solutions are welcome.

PS. I did not change anything in the rAvailability Calenda module. I'm just install modules - enable/disable - or change configuration.

3
  • I think if you will go to Configuration > Regional and re-select Monday and save it will be all right.
    – Nishant
    Jun 24, 2015 at 12:04
  • Thanks for the quick answer NishantP. But i tried that already and nothing is changing. It changed it the beginning, but the next day it was back to Saturday. Changing it now to any day does nothing anymore :-( Jun 24, 2015 at 12:12
  • Are you using drupal.org/project/availability_calendars or drupal.org/project/calendar? Please link appropriate module and be consistent about name you use in title and body of your question, to avoid confusion.
    – Mołot
    Jun 24, 2015 at 12:19

1 Answer 1

1

As a best practice whenever an issue like this arises - disable the module, uninstall, flush all cache, verify settings for regional locale is set to start on Monday.

Now re-enable the module. Flush all cache. Re-configure. And see if things are working as expected.

As an added additional option if you care to contribute to the community, on a fresh install of Drupal, attempt to recreate the issue that "potentially" caused this issue to arise by re-tracing any steps you may have taken (other contributed modules, other seemingly unrelated changes, etc.). If you're able to trace what caused the issue, then perhaps the potential bug can be fixed.

Of course, regardless if the uninstall, reinstall works and functionality doesn't again fail after a few days then you have solved your issue! This should be a fairly typical go-to strategy of troubleshooting for any module issue.

1
  • (Did this fix the problem? If so let's get this marked so people know it works.) Jun 26, 2015 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.