When I try to save a node I am working on I get this error message.

The content on this page has either been modified by another user, or you have already submitted modifications using this form. As a result, your changes cannot be saved.

What is causing that issue and how can I remove the lock?

  • it might be that you have two windows opened which are editing the same node. Close any other identical windows and refresh the page.
    – No Sssweat
    Jun 26, 2015 at 5:36
  • I am the only one editing the page and it is only from one browser page
    – vfclists
    Jun 26, 2015 at 6:52
  • hmm, have you tried clearing the drupal cache and clearing your browser cookies?
    – No Sssweat
    Jun 26, 2015 at 20:38
  • does it only happen on one content type or across any content type? If only one, is it a custom content type? are there overrides to the submit function or other hooks acting on the content type?
    – Geoff
    Jun 27, 2015 at 1:10
  • Related: drupal.stackexchange.com/questions/29954/…
    – leymannx
    Sep 15, 2017 at 16:00

4 Answers 4


Did you use the back button to get to your edit page? Have you tried manually going to the node and clicking the edit tab again to see if it reoccurs?

This message is caused when either (1) two users access the edit page and one user saves changes before the other user gets a chance or (2) when a user edits content, saves it, and clicks the back button to get back to the edit page.


Are there other users signed in? When all else fails (or rather the first step of troubleshooting always) Flush all cache. Clear your browser cache. Close your browser out. Re-open your browser. Attempt to recreate problem. Is it still happening?

  • requesting further information is more appropriate as a comment, not as part of an answer
    – Geoff
    Jun 26, 2015 at 1:25
  • 2
    The questions are rather rhetorical. They're questions that an individual can ask themselves to solve the problem. They're intended to assist anyone else having the same problem in both solving this exact problem as well as troubleshooting similar problems. The answer as it stands will solve the problem. Besides, sometimes the most appropriate answers are questions. (Also - new account means I can't comment ;) Jun 26, 2015 at 2:17
  • fair enough... but OP may not realise that on first read, that's the only reason I mentioned it
    – Geoff
    Jun 26, 2015 at 2:21
  • in fact I am looking for a module or a script that can fix the issue on the server side.
    – vfclists
    Jun 26, 2015 at 6:53
  • Does this happen with only one node? Or does this happen with all nodes? Did you follow every step of the directions given? (And are you sure you didn't leave an edit window open on a phone, other computer, etc.?) Jun 26, 2015 at 15:51

I had the same problem on an international site and here it was the "Administration Language Module" that caused the troubles. JFYI.


If the problem is related to two users editing the same record (node), it can be related to max_input_vars in your php.ini

There are two solutions to solve the problem (I recommend trying both of them):

  1. Edit phpi.ini and increase max_input_vars (find max_input_vars = ... and increase it). php.ini can be found in different locations for example in an ubuntu conventional setup it can be at /etc/php5/apache2/php.ini
  2. Clear cache (depend on your browser this is a pretty easy routine and you already do not know it, just google it).

Try to :

truncate the 'cache_form' table.

clear caches.

  • It would be nice if you could go into more detail about why the asker should do this and describe your answer a bit more.
    – mradcliffe
    Jun 5, 2017 at 17:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.