1

I have the autosave plugin for CKEditor enabled and working, but I want to change from some of the default settings (specifically save detection selectors and autosave_delay) and can't get the settings to "stick". I have been editing ckeditor.config.js (in modules/patched/ckeditor/) and, while that's executing, the settings changes aren't making it to the editor instance running on the page. I've also hacked at ckeditor.utils.js because I was able to get closer to the actual instance but I know that isn't best practice and I'll regret it down the road.

Drupal7 fyi

1

You can define (extra) config options in a CKEditor profile. Go to example.com/admin/config/content/ckeditor then select the editor profile(s) in which you have enabled autosave and go to the "Advanced Options".

In the "Custom JavaScript configuration" field you can override config options like

config.autosave_saveDetectionSelectors = "a[href^='javascript:__doPostBack'][id*='Save'],a[id*='Cancel']";
config.autosave_delay = 5;

No need to alter any of the javascript files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.