I did upgrade on Drupal 7 and imported these sites and database from localhost to another server. On localhost everything works well, on the server I can´t log to Drupal as admin. After entering password every browser shows similar message:The connection to the server was reset while loading page. When I want to change address in browser after that I have to delete all history, cookies, cache, etc., otherwise it writes the same message. I changed base_url, cookie_domain in settings.php, deleted cache and session tables in database. It didn't help.


  • Putting /?=admin doesn't work, I am redirected to homepage, even on my localhost page where I can login .htaccess has the same content as old .htaccess

  • My pages are on web hosting. I am not sure if I can restart webserver by myself.

  • About server log messages: any special thing except of missing of favicon.ico in folder. I repaired it.

  • I tuned the .htaccess file. I don't see effect for a while. Maybe after server restart?

  • I don´t have Coder module.

  • my web hosting doesn't allow me increase stack size. Is this problem always connected with some Drupal module? Is somewhere some list of Drupal modules which causes page reset after admin login? Code module isn't my case.

This problem was finally solved by Php upgrade on the side of hosting server!

  • Can you get to your admin pages by putting /?=admin or is that broke also? Did you have any custom rules in .htaccess that maybe the upgrade overwrote? There are really a lot of different things that can be wrong here. Make sure your .htaccess is even present also. Here is another thread where they have the same issue: drupal.org/node/1777128 Jul 2, 2015 at 19:37
  • Please note that your "answers" are not what are "answers" are for. Instead you should EDIT your question, eg via the "notes" that I just added (= a kind of copy of what your answers indicated). Please review the "notes" I added here (to help you), and refine where needed. Also: visit the help pages and the tour, via the link in the upper right ... Just trying to help to get you going on Drupal.SE ... Jul 3, 2015 at 6:01

1 Answer 1


Restart webserver

Might be a webserver issue. Try restarting you webserver and check if it solves your issue.

Check server logs

If that doesn't help either, check your webserver's error log to see if there is any special error message in these that helps.

Tune the .htaccess file

Modified the .htaccess file and replace the default clean URL rewrites with this:

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !=/favicon.ico
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

Coder module

  1. Option a: Remove the Code module

    A complete different reason for this issue is Coder makes Drupal go to "Connection was reset" browser error. So if you have the Coder module installed/enabled, then disable and uninstall it and ALSO remove that module from the module folder.

  2. Option b (if using WAMP): increase the stack size

    Be aware that preg_match_all uses the stack which may be too small. PHP crashes and then Apache crashes (and restarts). The fix is to increase the stack size to match a default Linux PHP Apache setup. To do so, increase the Apache stack size to 8MB by adding a line to the end of httpd.conf (surrounded by a IfModule mpm_winnt_module and matching /IfModule tag):

    ThreadStackSize 8388608

    After restarting the webserver you can then use any version of the Coder module (and other modules which have this issue ...).

    More details: https://www.drupal.org/node/1597820#comment-6094060

  • option "b" works like a charm. thank you. Apr 19, 2016 at 6:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.