I am working to install Aegir on an AWS EC2 instance (Amazon AMI) using an RDS mysql database. So basically a virtual box with a remote DB server. I am using the manual procedure and am running into problems at the hostmaster-install phase. The remote mysql server is correctly identified and the logon is accepted but the install fails. Here is the command I am running:

drush hostmaster-install --aegir_db_user="root" --aegir_db_host="the_FQDN_of_the_remote_DB_server"

Install starts great but the starts giving warnings and errors which obviously have to do with problems running MySQL commands. Here is a small excerpt:

MySQL server has gone away [warning] query: SELECT filename FROM system WHERE name = 'jquery_ui' AND type = 'module' database.mysqli.inc:134

MySQL server has gone away [warning] query: CREATE TABLE variable ( name VARCHAR(128) NOT NULL DEFAULT '', value LONGTEXT NOT NULL, PRIMARY KEY (name) ) /*!40100 DEFAULT CHARACTER SET utf8 */ database.mysqli.inc:134

I noticed that the database was not created, so any table attempts will also fail. The question is why is the database not created? I am not getting any clear output indicating this. I ran the command with the --debug option, but did not get any additional information to point out why it is failing.

Amazon Web Services (AWS) RDS service does put some limitations on the "root" user. For instance it does not have the "SUPER" privilege and also does not have the "CREATE TABLE SPACE" privilege. Could these be a reason fro the failure?

Where can I see what exact SQL commands are being run? I would like to try and run them manually to debug this issue.

Of course if anyone out there has successfully installed directly on to AWS with RDS as a remote DB, I'd love to know how.

Thanks, Eric

  • You could enable full query logging on a local mysql server just to test... – Herman van Rink Jul 4 '15 at 21:14
  • @Eric, did you ever get this sorted out? Did the answer from cweagans help? – htoip Mar 14 '17 at 21:48

You're getting the error "MySQL server has gone away". Usually when this happens during Drupal installation, it's related to MySQL's max_allowed_packet setting. I'd recommend bumping that value up to 32MB. The process for changing that value on Amazon RDS is detailed here: https://survivalguides.wordpress.com/2012/02/02/change-the-max_allowed_packet-amazon-rds/

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.