I'm trying to install Drupal 8 on my laptop (localhost on a WAMP server), and I always get the following error in the first steps:

Requirements problem

The translation server is offline.

The installer requires to contact the translation server to download a translation file. Check your internet connection and verify that your website can reach the translation server at http://ftp.drupal.org. Check the messages and try again.

That step is mandatory, and I can't continue the installation process. Opening http://ftp.drupal.org, I can see the website with no problem.

I've disabled anti-virus and firewall, and I have tried the process from different locations (different Internet access) on the same computer, with the same result. I'm using EasyPHP WAMP on Windows 8.1, with versions that meet the requirements of PHP, MySQL.

What can be blocking the access to the translation server? Is there any way to omit this step?

up vote 15 down vote accepted

I think you didn't select English in the first step, and probably your Internet connection is behind a proxy and I guess Drupal doesn't support it.

You can select English and continue or:

  1. Go to Translation server and download the specific language, the Spanish for example

enter image description here

enter image description here

  1. Copy the download file in sites/default/files/translations
  2. Continue with installation

Download this file : https://curl.haxx.se/ca/cacert.pem

And add the path to the file in your php.ini :

curl.cainfo="D:\wamp64\keys\cacert.pem"
  • 1
    While this might solve the problem, it doesn't explain why it solves the problem. Please address why changing CA cert could fix the problem. – Shawn Conn Sep 29 '16 at 20:19
  • When the install fail. Go to core/includes/install.core.inc and modify this function : – Yann Choquet Sep 30 '16 at 20:52
  • install_check_localization_server() for add in catch var_dump($e->getMessage()); this function return : cURL error 60: SSL certificate problem: unable to get local issuer certificate (see curl.haxx.se/libcurl/c/libcurl-errors.html)` drupal.stackexchange.com/questions/164172/… – Yann Choquet Sep 30 '16 at 21:02

This situation can be derived from invisible exception: Unable to find the wrapper "https" - did you forget to enable it when you configured PHP?

To solve this problem you need to activate (uncomment) "php_openssl" module in php.ini:

extension=C:\xxx\php_openssl.dll

Before edit php.ini you can test your situation by small php script:

<?php
error_reporting(E_ALL);
$file = file_get_contents('https://www.google.com/');
die($file);
?>

If it return "Unable to find the wrapper "https" - did you forget to enable it when you configured PHP?", you should edit php.ini and RESTART Apache windows service.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.