2

I have a problem of admin not having full access to content nodes. I wanted to create a view so that a user can see nodes he created and cannot see other users' nodes. However, 'admin' should be able to see all available nodes without any restricts, even if made.

My problem is that, when it comes to restricting the users to see only their nodes posted. Strangely the admin was included to see only his own posts as well! (even though the settings where telling me that whatever setting I make, the admins will not be affected) but that doesn't seem to be the case.

Does any one have any idea or suggestion?

I have gone to permissions, and checked ALL values to be selected. I rebuild the permission. Yet, this is happening.

Just in case I thought some module might be interfering, I had NodeAccessdisabled and some other modules, but the result is the same! The admin is not getting a full view as supposed to when restricting!

Here's a screen shot of a user view and admin, currently as an admin (aziz here), this is what I see (3 nodes created by admin):

admin view

and those are the setting:

settings for admin

While on the other hand, when I created another view WITHOUT restrictions, it shows all nodes:

all nodes

and here are the settings for it:

setting for all

Anyone has any idea why the admin is included in restriction?

Let me know if you think there's anything wrong here. Because based on my other question is the post " how to view data row table related to user only?" I was advised to follow these setting (as in image, and the user who advised is working very well with him). But I think that there's something interfering with my admin role for not letting it bypass restrictions made (at least, even when I do restrict the view for users, admin shouldn't have been included).

My last hope in the admin restriction is creating 2 views for every content type, which is quite troublesome.

I hope I gave clear picture.

1

In your 2nd screenprint, within "filter criteria", the last line of it is says "Content: Author uid (=aziz)". That doesn't seem to be correct ...

Make sure the filter criteria only has "Content: Author uid" without "Author user: current". And keep the ID blank for the author uid, because specifying the user will only refer to the nodes published by THAT user only.

  • When filtering on Content:Author UID, it presents an autocomplete of user names, which then get translated, the instructions: "Enter a comma separated list of user names.". Entering a number gives an error – Geoff Jul 3 '15 at 19:50
  • Thanks for the note guys..but it seemed to me that the "content:author id" was asking which username to write down!! based on the suggestions given by you guys, i removed the username and left it blank for author uid, adding that i mistakenly removed (author) current user..and IT WORKED!! .. now with only "content :author uid" just like that it shows the data based on user role as i wanted. – Abdulaziz Hamdan Jul 4 '15 at 7:34
  • @Pierre.Vriens i noticed something as well which seems related! the content types' access control settings! .. i think the access control was not set to "view own"..so even though at permissions at everywhere says view own data only..but that access control at content type was the one leaking the permission for everyone to see, cuz it was not set!! – Abdulaziz Hamdan Jul 4 '15 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.