1

Background

I have a Drupal 7.38 folder subsite (i.e yoursitesname.com/test). The site was installed with softaculous, and has only few core modules enabled. When I come to install the last version of Views, or alternatively, References, I get this error:

enter image description here

You can see from the first screen that the error tells me to continue to the "errors page" and this is what I see when I continue

enter image description here

Already tried and didn't help

Some of the solutions were found in Google search:

  • Flushed all caches.
  • Installing from a downloaded file, instead of a link in Drupal.org.
  • giving 755 permissions to all the homefolder files (including .HTaccess and all files in sites/default folder).
  • Changing PHP version for main folder (i.e yoursitesname.com) from PHP 5.3.29 to PHP 5.5.26

Any suggestions?

2 Answers 2

1

Here is a list of items to check:

  • Clear all caches (it doesn't hurt, and occasionally helps solving various issues): if you get a WSOD while doing so, it indicates memory shortage.
  • Try running update.php (by typing an URL like http://www.yourdomain.com/update.php): if you get a Fatal error like "Allow memory size of ... bytes exhausted", it indicates memory shortage.
  • Verify if it is a memory shortage issue by increasing the memory a bit to check if there is any difference.

    Assuming this is NOT a multi site, consider editing your /sites/default/settings.php, and change the line to set the memory limit. If it is a multi site, then edit the settings.php file related to the site where you are experiencing the problem.

    That line in settings.php should look similar to this:

    ini_set('memory_limit', '100M');

    The '100M' in it might be some other number. Whatever the number is, try to increase it with like 50%, or maybe even double it to see what happens after you do so (of course do not forget to save the file after increasing that number).

    If needed, refer to https://www.drupal.org/node/207036 for more details, eg if such 'ini_set' is not yet included in your settings.php file. As mentioned in that link: "Locate the PHP settings section and add that line at the end of that section".

5
  • Thanks for the detailed response! some details: It's not a subsite... there is no error or problem while clearing caches. How do you run update.php?, I can't find such a syntax --- ini_set('memory_limit', '100M'); --- in settings.php ... Not in the subsite and not in the original site's settings.php ...
    – user16289
    Commented Jul 8, 2015 at 21:52
  • Expanded my answer a bit to address your prior comment ... curious to hear if that will help ... Commented Jul 8, 2015 at 21:54
  • Ran PHP in both sites (original and folder subsite), there where no problems... I also expanded the subsite' settings.php in the only section that contain the word "memory" (please see image in the bottom of my question). The error still appears...
    – user16289
    Commented Jul 8, 2015 at 22:20
  • Updated the question with more data.
    – user16289
    Commented Jul 8, 2015 at 22:32
  • Hm, that's different from memory problems then ... Seems like you need to find the module that causes that error, disable/uninstall that module, and then enable that module again. Doiing so you will trigger the logic in the .install file again, which might (re-) create the "undefined" index ... please keep me updated when you have more news on that Commented Jul 8, 2015 at 22:45
1

The site was installed via Softaculous platform (Cpanel software). The original isntallation included some non-core modules and I removed all of them to the situation I had only core-modules... Yet, for some unkown reason, it prevented me from installing modules by the aforementioned error. But now... After I deleted the Softaculous install and installed Drupal 7.38 in the traditional "manual" way, the sub-site worked fine... It might be a bug in the current release of Softaculous, that prevents installation of modules in sub-sites.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.