2

I have enabled clean URLs on the site after various article has been published on the site.

But when I migrate from Bluehost VPS to Bluehost Share hosting, the clean URLs is not accessible again. And when I remove ?q= I will see the enable box, and it has lead to duplicate URL on articles on the site.

0

To correctly enable/configure Clean URLs, refer to Configure Clean URLs in the installation guide.

If you're not familiar with Clean URLs yet, I suggest to review that documentation in the installation guide carefully (for the version of Drupal that you're using) and make sure your server is correctly configured before proceeding.

Here is a summary of common steps/issues:

  • With Apache HTTPD as web-server, you have to enable mod_rewrite and configure the necessary rewrite rules in the .htaccess file.
  • Usually, theses rules are applied automatically, when mod_rewrite is enabled. But in some cases, the AllowOverride directive is too restrictive to allow this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.