0

I had to turn on aggregate and compress CSS and JS for my site as the performance was terrible and I was getting a lot of CSS errors (admin bar would disappear intermittently or not load correctly or other CSS errors)

Activating the aggregation improved page load times dramatically and solved all my other CSS issues, however, now I get an error with the metatag module in which the field sets for Open Graph, Facebook etc. won't load as hyperlinks which can be expanded, only plain text.

The issue seems limited to the blog content type.

Any ideas where I can look to solve the issue?

drupal metatag options not exanding

  • If possible share the error screen shot as well.... – Atul Bhosale Jul 10 '15 at 20:02
  • I don't understand, can you not see the screen shot embedded in my post above? – Ashe Higgs Jul 10 '15 at 20:07
  • Yes, I can see the actual screen shot above. To more specific..... share the actual error which is displayed in console – Atul Bhosale Jul 10 '15 at 20:11
0

Most likely there is a parse error in a JS and or CSS file. Check the console for any error; fix them and try again.

  • sorry for the n00b questions, but how do I check the console? – Ashe Higgs Jul 11 '15 at 0:17
  • getfirebug.com/logging – mikeytown2 Jul 11 '15 at 0:19
  • I work mostly using Chrome OS these days, but if I use inspect element I do see that I get a 522 error on the following .js file - /sites/default/files/js/js_5lrzLVYmzJlz59v8vxohFpYcT_00TebFdDnQv26MYt8.js – Ashe Higgs Jul 11 '15 at 0:20
  • The 5xx error (support.cloudflare.com/hc/en-us/articles/…) on that js file is why the fieldsets are not showing up. Disable "Aggregate JavaScript files" but keep the CSS enabled and see if the fieldsets work. – mikeytown2 Jul 11 '15 at 0:26
  • that sort of helped. page loaded with all fieldsets expanded. With .js aggregation turned off, I'm actually getting 30 errors on page (it rendered like a mess) Where can I look to figure out why my site is having such a hard time serving up the css and js files? – Ashe Higgs Jul 11 '15 at 0:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.