2

I am trying to download a custom module from a private repo using drush make. This is the make file:

core = 7.x
api = 2
projects[cs_all][type] = "module"
projects[cs_all][subdir] = "contrib"
projects[cs_all][download][url] = "git@bitbucket.org:myrepo/cs_all.git"
projects[cs_all][download][branch] = "master"

I run the following command:

drush -d make --no-cache --no-core my.make build

The output is as follows:

Starting Drush preflight. [0.46 sec, 2 MB] [preflight]
Cache HIT cid: 7.0.0-commandfiles-0-4ea41d3d78dd4cb8ebf6ca2ee09bd808 [0.61 sec, 2.05 MB] [debug]
Bootstrap to phase 0. [3.31 sec, 8.02 MB] [bootstrap]
Bootstrap to phase -1. [3.35 sec, 8.03 MB][bootstrap]
Found command: make (commandfile=make) [3.36 sec, 8.03 MB] [bootstrap]
Bootstrap to phase -1. [3.36 sec, 8.03 MB][bootstrap]
Loading release_info engine. [3.38 sec, 8.03 MB][notice]
Calling hook drush_make_validate [3.42 sec, 8.23 MB][debug]
Returned from hook drush_make_validate [3.42 sec, 8.23 MB][debug]
Calling hook drush_make_pre_make [3.42 sec, 8.24 MB][debug]
Returned from hook drush_make_pre_make [3.43 sec, 8.24 MB][debug]
Calling hook drush_make [3.43 sec, 8.25 MB][debug]
Beginning to build my.make. [3.44 sec, 8.27 MB] [ok]
Downloading release history from https://updates.drupal.org/release-history/cs_all/7.x [3.45 sec, 8.35 MB] [notice]
c:/Users/myname/.drush/cache/download/https---updates.drupal.org-release-history-cs_all-7.x retrieved from[notice]
cache. [3.45 sec, 8.35 MB]
No release history was found for the requested project (cs_all). [3.46 sec, 8.36 MB][error]
Returned from hook drush_make [3.46 sec, 8.35 MB][debug]
Command dispatch complete [3.46 sec, 8.32 MB]

Basically drush looks for the module release history file on drupal.org.

I have not found any specific documentation regarding downloading from private repos. However various snippets taken from presentations show the same make parameters that I have used.

I am using drush 7.0.0., php 5.5.26 and Windows 7.

How to fix the issue?

  • if I add projects[cs_all][download][type] = "git" the result doesn't change. Git is the default download method, so it can be omitted. – adop Jul 11 '15 at 15:25
  • What happens when you swap the directory over to 'custom', I've never tried that before since I usually have something like this $projects[contrib] and $projects[custom] in my makefile that all of my projects fall under then but since it says "contrib" drush may ignore the rest, again I haven't looked at the code to be for sure but it's worth a shot. I can maybe post an example of one of my sites makefiles for you to see later. – burnsjeremy Jul 12 '15 at 2:30
  • burnsjeremy - I have just tried with projects[cs_all][subdir] = "custom", but it makes no difference – adop Jul 12 '15 at 7:20
  • Have you tried putting this custom module inside a "custom" array, like $projects['custom']['cs_all'] for all the definitions, is there anything else in the makefile that could be overwriting anything? Could you post the complete makefile? I don't have a Windows setup but I could run it (with one of my own custom modules) and see if it runs correctly on a Linux machine. Also, you do have you SSH access setup correctly right? Like you can perform a normal git clone for this repo from the same place that you are running the drush make command at. This is important... – burnsjeremy Jul 12 '15 at 7:49
  • You also can't put in a passcode for the ssh key during the make cmd, so you have to have the passcode already entered for the shell session. I did have to fix that for a coworker one time on Windows. He just had gave up on drush make and was building by hand, we had to use ssh-add and ran a command to enter his passcode at the beginning of him starting his shell session. You can google that or look it up in the bitbucket docs if you think this may be an issue. Drush may be just falling back since it doesn't have access to the repo or gets a failure from not being able to enter the passcode. – burnsjeremy Jul 12 '15 at 7:52
0

Add a line to the make file to make it look like so:

core = 7.x
api = 2
projects[cs_all][type] = "module"
projects[cs_all][subdir] = "contrib"
projects[cs_all][download][url] = "git@bitbucket.org:myrepo/cs_all.git"
projects[cs_all][download][type] = "git"
projects[cs_all][download][branch] = "master"

So add the line to indicate 'type = git' . That would make it look closer to what is documented on https://www.drupal.org/node/1432374 ...

Curious to hear what results you'd get then.

0

On my work I use private repo with custom modules and profiles, and works out of the box

Do you use a different ssh to access to your private repo?

And try to use drush cc drush just in case you have a corrupted files on your drush cache

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.