1

I use CKEditor to create content. And Media Plugin to upload and manage images.

Now I have a problem that as soon as I activate Advanced Content Filter in CKEditor settings, my images are removed. I think problem is, that they are implemented like this:

    <drupal-entity class="media-element" data-entity-embed-display="image:image" 
        data-entity-id="2589" data-entity-type="file" data-fid="2589" 
        data-media-element="1"></drupal-entity>

I tried to insert drupal-entity in extra allowed content, but it doesn't change anything.

As long as I do not save this node with activated ACF the images are shown on my website. This is because first I created nodes with deactivated ACF.

0
+50

Try this :

  • admin/config/content/ckeditor/edit/Full->
  • Advanced Options ->
  • Custom JavaScript configuration ->
  • Paste in: config.allowedContent = true;
  • Save
  • At the end I edited the config.js and set allowed_content to t. – Jurik Jul 21 '15 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.