2

I went to the ckeditor website made a custom build of an ckeditor with the plugins I want, then downloaded and extracted it to

sites/all/libraries/ckeditor

(I previously installed the libraries and ckeditor modules)

then I went to the global configurations settings for ckeditor

admin/config/content/ckeditor/editg

For the "> Path to CKEditor * " value I entered

%l/ckeditor

which sets the location of ckeditor to

/sites/all/libraries/ckeditor

and I set the " Path to the CKEditor plugins directory " value to

%l/ckeditor/plugins

which sets the location of the plugins to

/sites/all/libraries/ckeditor/plugins

I save the configuration and flush all caches. But whenever I go to edit a piece of content there is NO editor and NO body field at all on the page.

I can re-enter the default url used to install ckeditor and the editor will appear on the page, but of course, without my plugins. I have no error messages. Anyone have any idea why ckeditor can't find itself?

thanks

1

Just a quick answer to my question for other drupal noobies making the same error as I have. There seems to be a bit debate between installing stand alone ckeditor or installing ckeditor via durpal's wysiwyg module (convenient for installing multiple wysiwyg editors, if need that level of choice). For more info read this.

At the risk of drawing wrath, with drupal, "more modules" = "more chances for errors and conflicts" so I am go with the stand alone ckeditor install.

First install the ckeditor drupal module, from the drupal project page.

Then, download the BASIC ckeditor script library from ckeditor.com .

NOTE: DO NOT ATTEMPT TO ADD PLUGINS AT THIS POINT, JUST DOWNLOAD THE PLAIN, VANILLA, CLASSIC DOWNLOAD. This is what caused the error above, some plugins do NOT "play nicely" with drupal.

After you have the download of the plain ckeditor script library downloaded, place into the /sites/all/libraries/ directory, so that you end up with /sites/all/libraries/ckeditor/ckeditor.js file structure.

Then in your drupal site go to /admin/config/content/ckeditor and edit the "Global Settings" , so that the "Path to ckeditor" is %l/ckeditor (sites/all/libraries/ckeditor) and the "Path to plugins" is %m/plugins (sites/all/modules/plugins)

NOTE: By default ckeditor points to a web address (CDN) for the "path to editor" value, which is mighty inconvenient if you work offline on a local dev server without internet from time to time.

Save Configurations

Assuming your install was successful, meaning that you did not have any red text drupal messages at /admin/config/content/ckeditor page complaining about missing libraries, you can go to /node/add/page and see if your locally installed ckeditor is working properly. If it loads, you are good to go.

Now for the fun part, adding all those plugins that made your mouth water, but you couldn't add before you downloaded the ckeditor script library.

Go to ckeditor.com make a list of all the plugins that you desire for your local, stand alone editor, then download each plugin individually.

Extract each plugin that you downloaded to your sites/all/modules/ckeditor/plugins folder.

NOTE: DO NOT extract the plugins folder located in the drupal sites/all/libraries/ckeditor/plugins folder... all your neat plugins and hours of work will be wiped out when you update ckeditor in the future.

After all your plugins are extracted, edit your "ckeditor.config.js" file located at sites/all/modules/ckeditor.

look for "config.extraPlugins = '';" and enter the name of your plugin. For more than plugin, separate each plugin with a " , " .

For more details on plugin installation READ THE DOCUMENTATION HERE.

I highly recommend, adding plugins one at a time and testing in your browser, so that you can easily remove the mean plugin that won't play nice with others.

At this point go back to /admin/config/content/ckeditor and edit INPUT FORMAT that you want to use with ckeditor. Look under "Editor Appearance" and scroll down, your added plugins should appear as checkbox options. Select the ones you want...then get back to "drupaling" :-)

|improve this answer|||||
0

Great tutorial! My only addition would be: After you enabled the module and set the global settings as described, you have to turn on the CKEditor for the Advanced Text Format configuration here: /admin/config/content/ckeditor/edit/Advanced (under Basic Setup)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.