I am trying to setup a Drupal 8 Environment on Virtual Machine (Ubuntu) and when I am trying to clear cache, I've got the error:

drupal8@drupal8-VirtualBox:/var/www/drupal-8.0-alpha5$ drush cc all
Command cache-clear needs a higher bootstrap level to run - you will [error]
need invoke drush from a more functional Drupal environment to run
this command.
The drush command 'cc all' could not be executed.                    [error]
A Drupal installation directory could not be found                   [error]

I have installed Drush, but getting this error. Can anybody help me with this?

  • Try 'drush cc' command
    – Aparna
    Jul 16, 2015 at 12:34
  • @Aparna, 'drush cc' gives the same error above..
    – meen
    Jul 16, 2015 at 12:37
  • What version of drush are you using? Only the 7.x branch supports D8. And does this D8 installation respond in a web browser?
    – Brady
    Jul 16, 2015 at 12:53
  • You would need an old version of Drush to run drupal-8.0-alpha5. The Drush 7.x branch no longer supports Drupal 7, as of the release of Drush 7.0.0. Drupal 8 users are better off updating to a recent version of Drupal 8 and Drush 8. Jul 16, 2015 at 14:14
  • Drush version is 4.5
    – meen
    Jul 17, 2015 at 7:04

4 Answers 4


There are a few possible reasons for the issue you're facing, as further detailed below ...

Drush commands need to be issued from within the correct subfolder

A "possible" reason might be because Drush commands must be issued from the appropriate subdirectory of your website (change to the directory where your Drupal site is installed and try again).

So try navigating to the sites/default folder (assuming this is NOT a multi-site), and then retry your Drush comand.

Use the Drush version that supports your Drupal version

It could well be an issue with the version of Drush that you are using. Check if it is an option to downgrade to a lower version of Drush? FYI: Drush 7.x does support D8 also ...

Note: in one of the comments in the question, the OPer wrote "Drush version is 4.5". Haven't double checked it yet, but that appears to be an extremely old version of Drush. I wouldn't be surprised if that version doesn't support D8 "yet". And since the D8 folder structure changed quite a bit, that would also explain the error like "A Drupal installation directory could not be found" ... More research (and clarifications from OPer) are seems appropriate here ... (I might update my answer here later on with some relevant pointers about "which version of Drush supports which version of Drupal".

  • I have to agree with @Pierre.Vvriens. Perhaps /var/www/drupal-8.0-alpha5 where you run the command isn't the root of the Drupal site or you don't have the correct Drush version.
    – albertski
    Jul 16, 2015 at 13:49
  • @Pierre.Vriens, i am curently in drupal's root directory. Also tried executing the 'drush cc all' command in sites/default, resulted in same error.
    – meen
    Jul 17, 2015 at 8:30
  • PLease refer to my updated answer, and EDIT your question about the exact vrsion of DRUSH you're using for this D8 install, ok? Jul 17, 2015 at 8:47

drush is not recognizing your site settings.
Run drush -d to see where is it failing.
For anyone having this problem using acquia dev desktop, see this answer.


The issue may be that you are using an old version of Drupal 8 (alpha-5). At this time Drupal 8 is at Beta 12. Upgrading may solve this issue but keep in mind there were major changes happening during development so upgrading won't be that simple. If you don't have a lot of nodes it might be easier just to start fresh.


drush command for Drupal 8 is 'drush cr' or 'drush cache-rebuild'. Cache is no longer only being cleared, as in the cache tables truncated in the databases, but the site was being rebuilt as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.