0

Hi everyone when I am trying to add token to create auto label error is showing can anyone tell me that how to resolve it?.

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 46026417 bytes) in C:\xampp\htdocs\mcms\includes\database\database.inc on line 2171

enter image description here

default settings.php

2

You can also try

put the below code in your settings.php file.

ini_set('memory_limit', '256M');

Do not forget to restart xampp.

| improve this answer | |
  • where exactly need to add? is it at the bottom of settings.php file. – rose Jul 20 '15 at 6:28
  • you can add anywhere in side settings.php otherwise search ini_set in settings.php you will find some commented line add just below it. – DRUPWAY Jul 20 '15 at 6:31
  • I searched for ini_set but it saying like cant find such text. i have added the screenshot even.please have a look – rose Jul 20 '15 at 6:36
  • ok put anywhere in the settings.php – DRUPWAY Jul 20 '15 at 6:54
  • I did it but still its not working @smalution – rose Jul 20 '15 at 6:59
1

It's likely the number of tokens is pushing PHP to its memory limits. Go into your /etc/php.ini file, update the memory_limit to something higher than 128MB (e.g. memory_limit = 256M) then restart your webserver.

| improve this answer | |
  • I will try this and get back to you, and thanks for your response. – rose Jul 20 '15 at 6:14
  • i tried still its the same @shawn conn – rose Jul 20 '15 at 6:47
  • Did you restart your web server? Checkout the status page on example.com/admin/reports/status to see if it reporting the 256MB memory limit. – Shawn Conn Jul 21 '15 at 5:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.