In drupal 7, I created block in views and add field Global: Custom text, and write some text in this field.

When display this block and inspect show Global: Custom text in span tag.

How to display Global: Custom text but not in span tag.

  • Did you unchecked the checkbox "Create a label" in the settings for this field?
    – Andrew
    Jul 20, 2015 at 11:49
  • Did you checked the "Exclude from dispaly" option..?
    – Abin
    Jul 20, 2015 at 11:50
  • Create a label checkbox is unchecked. Jul 20, 2015 at 11:50
  • @Abin, i want to display field, but not span tag. Jul 20, 2015 at 11:52
  • It will create a wrapper element, unless you modify the field tempalte
    – niksmac
    Jul 20, 2015 at 12:05

2 Answers 2


You can turn them off in "Global: Custom Text" field setting. Just check the "Customize field HTML" and "Customize field and label wrapper HTML", and set both elements to "None" in "Style Settings". See below screenshot for details. enter image description here


you can choose Global Php variable from listing when add different varible of content type from listed variables in view.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.