0

I have submit the custom form using batch process in which process I have upload big xml file(min 200MB) and read xml file and inserted xml data in database

but after 30~35 minits batch process display the

504 Gateway Time-out error.

Also I have increased memory size, excution time, max upload size and so on.

Please help me..

2 Answers 2

1

I have find the answer...

Please increase memory limit, excution time and max input time.

1. File php.ini

memory_limit = 768M
max_execution_time = 3600
max_input_time = 3600

OR

Define in settings.php

<?php
    ini_set('memory_limit ', '768M');
    ini_set('max_execution_time', 3600);
    ini_set('max_input_time', 3600);    
?>

My problem is solve. :)

0

Use Background Process Module

This modules takes over the existing Batch API and runs batch jobs in a background process. This means that if you leave the batch page, the jobs continues, and you can return to the progress indicator later.

Batch jobs are delegated to the service host "background_batch" if defined

Not the answer you're looking for? Browse other questions tagged or ask your own question.