1

I have encountered a problem in my site. When the author of the node is anonymous, his/her content doesn't appear on the front page for anonymous users. but it does when the author is the admin.

Has anyone ever met the same issue and/or has a solution?

1

please check the permission in "admin/people/permissions" under the node section check View published content has been enabled for anonymous user

| improve this answer | |
  • cheked that permission for every user rôle – Ismail H Jul 24 '15 at 13:00
  • did you use Node View Permissions module ..try this it should be work... – Vishnu Yadav Jul 28 '15 at 7:21
1

Have you checked the option Promoted to front page for that content type?

| improve this answer | |
  • Yes i unfortunatly did :( – Ismail H Jul 24 '15 at 13:00
1

Are you sure the node is published? Anonymous users are often able to submit unpublished nodes but not to publish them. And Administrators usually can see unpublished content, but anonymous can't. (Of course all these settings can be changed per the suggestion about permissions above.)

(BTW, the word "type" in your subject is misleading as you are referring to nodes or content, not the entire content type.)

| improve this answer | |
  • 1
    The node is published. And thanks for the notice. My english is bad and i often have problems delivering the idea. with the right words. – Ismail H Jul 24 '15 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.