2

Background

I use Drupal 7.38 and Boost 7.x-1.0. According to Cron everything is up2date. I store my site at a (CentOS) NGINX-based shared hosting plan that seemingly does include UTF-8 encoding (my site is in Hebrew and the problem is language related). I have no idea if the following problem is a Boost bug or a fail, from my side, providing one of Drupal's encoding-related system requirements.

The problem

The Boost module is installed and working (verified it's work when visited root/sitename/cache...) but now, in the bottom of each non-English webpage, I get the following 2 errors:

  • Warning: Cannot modify header information - headers already sent by (output started at /home/user/public_html/sitename/includes/common.inc:2748) in drupal_send_headers() (line 1232 of /home/user/public_html/sitename/includes/bootstrap.inc).

  • PDOException: in dblog_watchdog() (line 160 of /ho/home/user/public_html/modules/dblog/dblog.module).

The exact whereabouts

These errors appear ONLY in non-English webpages... In English ones, they just don't appear... moreover, The cached webpage files that BOOST creates are named in Hebrew - i.e their file names are in Hebrew and actually resemble their H1. If I change the file name to an English one, and visit it from the site --- these errors no longer appear in it's bottom.

Maybe the server\Drupal\Boost fails to access the files correctly and and therefore prints these errors in their bottom. Note: It doesn't happen on a local Windows WAMP server, so it's likely the problem is in my online server and not in Drupal.

8
  • Sounds like a server environment problem to me. Could you pastebin the output of env?
    – Kartagis
    Jul 26 '15 at 7:47
  • Pastebin the output of env? Sorry, I don't know what this is... Can you please elaborate so I could check it out? Thanks for your help!!!!!! finally someone helps here with this.
    – user16289
    Jul 26 '15 at 7:49
  • Type env in console and paste the output on paste.debian.net, and paste the URL here.
    – Kartagis
    Jul 26 '15 at 7:57
  • paste.debian.net/286128
    – user16289
    Jul 26 '15 at 8:15
  • Try typing export LC_LANG=he_HE.ISO-639-1 in the console and repeating the procedure. If that doesn't work, try with export LC_LANG=he_HE.UTF-8. I'm not too familiar with Hebrew.
    – Kartagis
    Jul 26 '15 at 10:09
1

boost_deliver_html_page() sounds like the issue. In your settings set $conf['boost_message_debug'] = FALSE; FALSE is the default value for that variable, this being TRUE seems to be causing the issue for you.

8
  • I searched manually with ctrl+f but I didn't find the $conf sytax anywhere in the module's files or .HTacess (Might have missed it). But what I did found In Boost.module (line27) was define('BOOST_MESSAGE_DEBUG', FALSE); False was the default for it... Can you please tell me where is the syntax you mentioned? Thanks!!!
    – user16289
    Jul 29 '15 at 5:03
  • 1
    Settings.php file in the sites/default dir
    – mikeytown2
    Jul 29 '15 at 15:29
  • I couldn't find this syntax in Settings.php also so I just copied this it into it, saved, went to Drupal and flushed all caches... The first error (headers already sent) was disappeared but the second error keep appearing in the bottom of each Non-English page... :\
    – user16289
    Jul 29 '15 at 22:39
  • 1
    Second error is most likely related to this drupal.org/node/1314214
    – mikeytown2
    Jul 29 '15 at 23:01
  • 1
    I'm not sure if converting the db collation from utf8 to utf8mb4 will help but that's all I got for you in terms of help. Does the final error go away if boost is disabled?
    – mikeytown2
    Jul 30 '15 at 23:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy