1

I generated a widget on pinterest. The result is the following:

<a data-pin-do="embedPin" href="http://nl.pinterest.com/pin/1438168111370/"></a>
<!-- Please call pinit.js only once per page -->
<script type="text/javascript" async defer src="//assets.pinterest.com/js/pinit.js"></script>

pinit.js is included in the theme and is available in the page.

I added a block with the following code.

<a data-pin-do="embedPin" href="http://nl.pinterest.com/pin/1438168111370/"></a>

When I saved the block (I used CKEditor), it cleaned. Actually, I don't know if it is cleaned by CKEditor or the full HTML filter.

How can I find out which of those is cleaned out the markup?

  • If it's due to CKEditor, how can I solve it? The advanced content filter is disabled.
  • If it's due to full HTML filter, how can I configure it so that only this non compliant syntax is allowed?

NOTE: In the full HTML filter, the checkbox Correct faulty and chopped off HTML is NOT checked.

  • In the Full HTML input format do you have "Limit allowed HTML tags" or any other HTML limiting filters? It is possible to have them enabled even though it is called Full HTML. – rooby Jul 30 '15 at 2:04
2

I've had the same issue with CKEditor removing classes in the past, Full HTML is not the issue.

Add the below code to the end of your CKEditors config.js file, which is found within the CKEditor library code.

CKEDITOR.config.allowedContent = true;

You might find that the file is called ckeditor.config.js and that this is the file that needs to be changed rather than the default config.js. This file can be found in the root of the CKEditor module.

  • Perfect solution !!! – Justme Jul 30 '15 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.