2

I am trying to get Drush running on my local development site. Drush & Cygwin are installed and the cygwin command prompt responds to Drush commands such as "Drush topic" but precedes the command output with:

"which: no tput in + a long list of directory paths"

and then gives the topic list. When I respond with 16 (Drupal help for error messages) I get:

fwrite(): supplied argument is not a valid stream resource [warning] output.inc:29

I believe I have to add path definitions, but am not certain where to define them. My current configuration on a windows OS has apache & php under C:/Program Files/acquai drupal/ (I used their setup for php and apache, but not their Drupal Site setup.) I have Drush located under C:/Drush and my site located under C:/Documents and Settings/admin/my-site.

3

Ashlar seems to have found a solution to the tput problem in his own bug report 'by adding the add-on gygwin command tput from the cygwin installation program "setup.exe". The actual command i not on the list. Look for the "ncurses" package which includes the Tput utility.' ... see http://drupal.org/node/1361510#comment-5327144

  • +1 Hey Thanks. I forgot to come back here when I worked it out, I appreciate your catching that! – Ashlar Jan 29 '12 at 19:09
1

Have a look at Drush Windows Installer (old instructions).

This package installs a standalone Drush, and adjust the Windows PATH to point to itself and its supporting executables. You can use this to learn how to set the PATH.

  • Thanks, That is what I used to install Drush in the first place. I reinstalled it, but no change. I submitted the problem as a bug report, so we'll see if they have any ideas. – Ashlar Dec 5 '11 at 15:16
  • OK. Also, I did get to my Drush Windows environment, and tried "drush topic", selecting item 16. I was able to see your error. Good luck with the issue! – rickumali Dec 6 '11 at 4:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.