0

This is incredibly frustrating. Here's the deal. I have a drush alias defined for a server I'm working with. No matter what command it is, if it needs to bootstrap Drupal it fails with no drupal site found or some variant. Running drush with --debug gives me less than useful information although if you'd like to see it I'm happy to provide it.

I can run drush @alias sqlc and get the mysql command line on the remote server. I just cannot run things like drush @alias st or drush @alias cc all for example.

If I SSH to the server, change into the directory (i.e. /sites/default) and run the same commands they work fine. So this is only when going over a remote alias.

Here's the alias definition:

$aliases['alias'] = array(
     'uri' => 'site.com',
     'root' => '/usr/share/nginx/html/drupal/docroot',
     'remote-host' => 'us-west-2.compute.amazonaws.com',
     'remote-user' => 'ubuntu',
     'ssh-options' => '-i /Users/name/.ssh/id_rsa -q',
     'db-url' => 'mysql://dbuser:dbpassword@localhost/www',
     'path-aliases' => array(
       '%files' => 'sites/default/files',
       '%dump-dir' => '/tmp'
      ), 
      'command-specific' => array (
        'sql-sync' => array (
          'no-cache' => TRUE,
        ),
     ),
);

Am I missing something here? I've done this a thousand times and for whatever reason this time it refuses to work.

Note: I have downgraded to Drush 6.x just in case it was a 7.x problem. Same result.

  • 1
    Is your settings file in sites/default/settings.php on the remote? Or is it in a subdomain? – Queenvictoria Aug 1 '15 at 0:17
  • That's what's so odd. It's in the default folder. Everything works fine on the server. – webkenny Aug 1 '15 at 2:25
  • 1
    Try removing the dburl from your aliases file. If that works I'll create an answer. – Queenvictoria Aug 1 '15 at 2:58
  • Thanks for the tip but that seems to fail. Here's what I get when I run drush @myalias.www st... Minmi:~ ksilanskas$ drush @myalias.www st PHP executable : /usr/bin/php PHP configuration : /etc/php5/cli/php.ini PHP OS : Linux Drush script : /home/ubuntu/.composer/vendor/drush/drush/drush.php Drush version : 7.0.0 Drush temp directory : /tmp Drush configuration : Drush alias files : – webkenny Aug 1 '15 at 14:54
0

Well this is embarrassing.... The problem was my %root directive. I had an additional directory tacked on. It was usr/share/nginx/drupal/docroot. Not no html in the path.

Upvotes for @Queenvictoria though for commenting and getting me to realize my error by poking back in the alias file. Thanks!

  • Glad you found the solution. It had to be something simple! – Queenvictoria Aug 1 '15 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.