1

I am getting this Error

Warning: Cannot modify header information - headers already sent by (output started at /home/aigair1/public_html/site1/sites/default/settings.php:1) in drupal_send_headers() (line 1236 of /home/aigair1/public_html/site1/includes/bootstrap.inc).

Warning: Cannot modify header information - headers already sent by (output started at /home/aigair1/public_html/site1/sites/default/settings.php:1) in drupal_send_headers() (line 1236 of /home/aigair1/public_html/site1/includes/bootstrap.inc).

Warning: Cannot modify header information - headers already sent by (output started at /home/aigair1/public_html/site1/sites/default/settings.php:1) in drupal_send_headers() (line 1236 of /home/aigair1/public_html/site1/includes/bootstrap.inc).

Warning: Cannot modify header information - headers already sent by (output started at /home/aigair1/public_html/site1/sites/default/settings.php:1) in drupal_send_headers() (line 1236 of /home/aigair1/public_html/site1/includes/bootstrap.inc).

I don't get this when my website in Localhost(Xampp), But When I upload site to web I get this. What's problem ?

Here is the Setting.php file as txt

  • did you check this post: is.gd/CbgSgu – shrish Aug 5 '15 at 5:57
  • Clear all cache and check this Warning gone OR not? Let know what is result. – AddWeb Solution Pvt Ltd Aug 5 '15 at 6:17
  • @AddWebSolutionPvtLtd, Yes I did it but problem exist – Ali Aug 5 '15 at 6:19
2

There is an output in your settings.php file. Maybe a whitespace before <?php, maybe you closed PHP tag at the end of your file, can't know without seeing it. Inspect your file carefully.

Be sure to transfer your files in binary mode, and disable all automated conversions your FTP software may offer. Save files as utf8 without BOM, Linux line endings. That's the safest way. If your editor can't do that, use another.

As Daniel Tome correctly pointed out, it may be case of warning turned off on your localhost, not a transfer issue. But the things you need to check are the same either way.

|improve this answer|||||
  • I attached setting file in question – Ali Aug 5 '15 at 6:13
  • 3
    @Ali Don't - this is not a private support forum, this is Q&A site - knowledge base for all of us, and for future users. If you feel you need yo attach whole files, you are in wrong place. – Mołot Aug 5 '15 at 6:17
  • Sorry for URL, I fixed it. – Ali Aug 5 '15 at 6:21
  • 1
    Also it's possible that your localhost has warnings turned off and your web has warnings turned on. Molot's answer is the correct. Your settings.php is outputting probably at the beginning of the file. – Daniel Tome Aug 5 '15 at 6:43
  • 1
    @Ali No, it's worst way. You broke functionality you don't understand to avoid fixing error you made elsewhere. So wrong, on so many levels... – Mołot Aug 5 '15 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.