0

I am hosting an Acquia Drupal site on AWS: enter image description here

I currently have 2 sites both located in the sites folder: enter image description here

I am fairly new to working with Drupal Multi-sites and would like to know what is the best way to point to each folder's settings.php with this format and ignore the sites/default folder?

And if it would be simpler in another format what would you recommend?

Let me know if you have any questions.

Thanks!

  • 1
    In you title you have "acquia", is this on an acquia server? Last time I worked on their server was with a multi-site docroot for Drupal 6, and it was difficult. Their configuration was not conducive but it eventually worked. – DeveloperWeeks Aug 6 '15 at 17:18
  • I'm also wondering why the AWS tag? Is that a by-proxy type thing (because Acquia use AWS) or is your own site hosted on AWS outside Acquia? – Clive Aug 6 '15 at 17:20
  • @DeveloperWeeks I added the "Acquia" work because that is what I see when I get the site running. – Lgalan90 Aug 6 '15 at 18:38
  • @Clive I am currently hosting my site on AWS. – Lgalan90 Aug 6 '15 at 18:39
  • This is a server configuration thing. I am not familiar with the AWS specifics, but you need the apache (or whatever engine) configuration to know it is listening for two urls. The multisite configuration guide seems to imply that the Drupal part will just know if the site addresses correctly match the folder names. – DeveloperWeeks Aug 7 '15 at 16:45
1

Assuming you have your web server (Apache, etc) pointing both sites correctly to your docroot, then Drupal will automatically route requests to the correct folder (and settings file) for each domain.

If you want to have it ignore the default folder and its settings.php file, you can delete the existing "default/" folder and create a symbolic link to one of your other two sites. For example:

ln -s alumni.something.edu default

and all requests to your docroot that don't match a domain in your multisites folder will be sent to alumni.something.edu (or whatever you prefer).

|improve this answer|||||
  • I ran this command: ln -s /var/www/html/sites/magazine.something.edu /var/www/html and now I a symbolic magazine.something.edu link in /var/www/html. When I go to EC2IP/magazine.comething.edu I get a: 403 Forbidden You don't have permission to access /magazine.something.edu/ on this server. Apache/2.2.29 (Amazon) Server at EC.2.IP Port 80 My permissions are set at 777 and I changed the following on my httpd.conf file: DirectoryIndex index.html index.html.var index.php index.htm index.sh Also, if I delete the .htaccess files I can see my files in the browser. Any ideas? – Lgalan90 Aug 17 '15 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.