0

My problem is that when I manually define teaser and body of the article, only the teaser displays after clicking "Read more" (the text entered in "Body" section isn't visible in any case)
I've defined max lenght of teaser to high value (2000) because I would manually set part of article which is visible in teaser mode but I think it should not impact on displaying full body.

  • Can you elaborate on "manually"? What is in the Summary, and what is in the Body? Are you using <!--break--> in the Body? – Dan Halbert Dec 6 '11 at 23:04
  • In drupal 7 there's no <!--break--> tag required (allowed?). In article edit-mode there are two fields (one for summary and another for full body) but in my case only text from summary displays. – Dawid Moś Dec 7 '11 at 10:09
0

It sounds like the "Format" for the Default display is wrong. What is the "format" value shown in http://YOUR.DOMAIN/admin/structure/types/manage/YOUR_CONTENT_TYPE/display? Typically it should be "Default". If the Default Display is set to "Summary or Trimmed", then you'll get the effect you mention, with the Summary in both the Teaser and Default versions.

You can check this by changing the settings and doing Preview on the node edit page. Preview shows the Teaser and Default versions simultaneously.

Also, is "Custom Display Settings" checked for the Full Content, or just the Teaser? Typically it would be just the Teaser. If you have set Custom Display Settings for Full Content, then check the settings as above.

By the way, <!-- break --> works fine in Drupal 7. I use it.

  • Solved, thank you! It wasn't exactly what you said but sth similar. I've to add separate display settings for full version of content (until now only the "Default" was set). Yes, you're right, <!--break---> works fine (I didn't know that because I was using only visual <WYSIWYG> solution) – Dawid Moś Dec 7 '11 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.