2

I have a Acquia DevDesktop2 set up on my development machine (win7). I'm testing a webform submission and I'm running into an issue where I get messages that the emails are sent, but nothing reaches the inboxes. I have I'm trying to email them to regular Gmail accounts. The vanilla install on my live site sends the emails without a problem, but I don't want to code on the live codebase.

I've seen that a lot of people have this issue, but there's no good documentation that I've stumbled across on how to set up the xmail server, or how to configure it after the fact. The acquia docs all say it comes cooked in, but I'm not sure why this doesn't work for me. Any references to how to trouble shoot this would be appreciated.

So any advice would be appreciated

3

Had the same problem and switched from XMail to Papercut recently:

Papercut is a simplified SMTP server designed to only receive messages (not to send them on) with a GUI on top of it allowing you to see the messages it receives. It doesn't enforce any restrictions on addresses, it just takes the message and allows you see it.

So, turn off the XMail service and start Papercut. When a mail is sent in Drupal, Papercut acts as the (local) SMTP server and allows you to see the message.

  • can you clarify where/how to do this? – nizz0k Aug 17 '15 at 22:31
  • sc stop "XMaill" – nizz0k Aug 17 '15 at 22:41
  • Of course there are different ways to stop a service on Windows, however, this tutorial seems to be an easy method. It should be quite similar for Windows 7. – Watergate Aug 17 '15 at 23:09
0

Many (most?) ISPs will block email sent via port 25. See Comcast's info on the subject: http://customer.xfinity.com/help-and-support/internet/email-port-25-no-longer-supported/

  • Ok...so how can I configure the xmail server that comes with dev desktop to use a diff port? Or what's a work around? – nizz0k Aug 17 '15 at 6:21
  • I am using the SMTP Authentication Support module. When you click configure for that module you will see the port specification that you can change. Start at the modules page or configuration. – Sam Stamport Dec 18 '15 at 16:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.