0

I am using CKEditor for client side text editing. All works fine. I see the content styled correctly when node is saved.

The problem begins when the node content is added to a view. The text styling font boldness is retained but the spacing options like indents are overridden by the view settings.

What I wish to do is to retain the CKEditor styling for the entire view display. Is there are option in Views to achieve this?

1 Answer 1

3

By default the text format filter "Limit HTML tags" will strip out "style" attributes in your HTML. You can't configure this via the admin but you can replace the filter with WYSIWYG Filter and configure that to allow specific styles whilst still filtering out dangerous HTML. The settings are found at /admin/config/content/formats/filtered_html (or replace "filtered_html" with the name of any other text format you need to alter). See this issue for pointer as to how best to set this up.

Please note though that if you're not sure what you are doing here then you may compromise the security of your site by setting up WYSIWYG Filter in a less than ideal way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.