0

I have a view with navigation set to paged, 12 items. I can see 12 items (there are way more available), but no pager. Googling this problem I found the following solutions that didn't work:

View uses Global: PHP fields (my view doesn't do that)

View is displayed in a block (my view is displayed in a page)

Changing pager id (tried everything from 0 to 5, also, this is the only pager on this page)

It's also not a styling issue, the pager is not in the markup. I didn't override any templates related to the view.

In other views, the pager works and I can also see it in the views preview. In this view, I can't even see it in the preview - this should prove that it's not a theming issue as well, am I right?

I tried displaying a "more" link, but that didn't work as well. Changing the navigation to "mini pager" also doesn't help.

The view is using a relationship to an entity reference, but that shouldn't be an issue IMO. Other than that it's a pretty ordinary view displaying some fields. Anyone have any ideas?

(Drupal 7, Views 3)

  • 1
    Do you have any pager plugins enabled? And is the view set to be cached? – Clive Aug 18 '15 at 17:00
  • 4
    possible duplicate of Pager doesn't work in views block if views php field is used – M a m a D Aug 19 '15 at 5:46
  • Drupalist: No, not a duplicate, as I said in the question, I'm not using such a field and don't even have this module installed – 1nterference Aug 19 '15 at 8:30
  • Clive: No, don't have any pager plugins or caching for this view enabled. – 1nterference Aug 19 '15 at 8:31
  • 3
    I'm voting to close this question as off-topic because it is about an old bug that been fixed, so it is no longer on topic here. – Free Radical May 19 '16 at 6:03
0

I'm guessing you have caching enabled for this view. You can disable caching for this view or, better, you can apply this patch: https://www.drupal.org/node/1819538

  • No, caching is disabled for this view. – 1nterference Aug 19 '15 at 8:31
0

This is a bug in Views Php module,there is a patch for that: Pager disappears when Global: PHP used in Views 3.8

After upgrading from Views version 7.x-3.7 to 7.x-3.8, the pager was missing from all views that used Global: PHP fields.

I had the same problem and #6 worked for me ,If patch#6 does not work for you, just follow the links in #27

  • Question states "View uses Global: PHP fields (my view doesn't do that)". I'm not using the Views PHP Module. – 1nterference Aug 19 '15 at 8:27
  • @1nterference It is not important you use or not use Php fields, try it please – Yusef Aug 19 '15 at 10:13
0

I found the issue, the View was set to display as a Display Suite Layout and the pager field was hidden in the settings of the Layout.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.