I'm new to Drupal and despite making progress over the last few days I've hit a problem.

I've got two custom content types linked with an entity reference. I'm using the Views module to create a relationship between them and output the results as a block. The block also uses a contextual filter.

All of this is working ok, I add the block to a page and the content is shown exactly as expected, except I don't get the edit/view tabs that I usually see above nodes.

If I navigate to the node by itself via the 'find content' page the edit tabs are there, but once inside the block they're missing.

I found one post mentioning that edit tabs don't appear as standard when contextual filters are used, but the post was three years old, had no solution or discussion, and and nothing to confirm whether it was actually true.

I know I can add an edit link from the Fields menu in Views but it makes the UI look inconsistent.

I'd appreciate if someone could let me know:

  1. What exactly stops them from appearing.
  2. What to read up on to get them working again.


2 Answers 2


You found the answer already. The contextual links you're looking for are just not provided by the views module when using fields (except when you add them explicitly). If you use the node row style in views they're provided through the node system of drupal. For convenience and many more options there's a module for it: Custom Contextual Links


Thanks for confirming. The editing behaviour seemed so obviously inconsistent (always visible tabs for some things and hover menus for others) that I wasn't sure if I'd made an error somewhere. I guess my question should be 'how do I make the admin UI more consistent'. It looks like the module you recommended might help me with that. If I can get rid of tabs completely and have hovers for everything it should be a bit more intuitive to use.

Incidentally, it looks like this has been addressed in Drupal 8. Some discussion here for anyone interested: https://www.drupal.org/node/1874664

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.