-1

I use symlinks sites/default/cdn ( symlinks for /u01/cdn) instead of sites/default/files/. I've chmod two folders cdn is 777. But when I access the link admin/config/media/file-system and paste sites/default/cdn then displays following error; enter image description here

My permissions are:

enter image description here

Can you help me for my problem? please. Thank you.

Solution

I have found problem. Only disable SELinux. use command: setenforce 0 to disable SELinux.

closed as too broad by kiamlaluno Aug 24 '15 at 9:24

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    The perms on the symlink don't matter, it's the perms on the target file/folder you need to change. Is /u01/cdn a physical folder or something special? – Clive Aug 21 '15 at 10:28
  • Thanks @Clive have helped support for me. /u01 an ext disk(/dev/sda2 on /u01 type ext4 (rw)). and /u01/cdn is normal folder. could you tell me how I can change perm to folder, please?use chmod? – Trang Lee Aug 21 '15 at 10:36
  • And sudo -u [web-server-user] touch /u01/cdn/test works ok? No permission errors? – Clive Aug 21 '15 at 10:36
  • 'sudo -u apache' is not working. i Use 'sudo -v -u apache' and 'touch /u01/cdn/test' is successfully. – Trang Lee Aug 21 '15 at 10:44
  • chown -R www-data.www-data /u01/cdn? – ar7max Aug 21 '15 at 10:46
-1

I have found problem. Only disable SELinux. Use command: setenforce 0 to disable SELinux.

Not the answer you're looking for? Browse other questions tagged or ask your own question.