1

I'm trying to migrate entities from a D7 to a D8 site using this tut: http://www.metaltoad.com/blog/migrating-taxonomy-drupal-7-to-drupal-8

When I execute the migration I get the error:

The "skip_process_on_empty" plugin does not exist.

And then it just hangs.

I have this in my migrate yml file:

parent:
    -
      plugin: skip_process_on_empty
      source: parent
    -
      plugin: migration
      migration: custom_taxonomy_term

I tried changing it to skip_row_on_empty but get the same error regarding "skip_process_on_empty".

Here's the contents of [mymodule]/config/install/migrate.migration.custom_taxonomy_term.yml

id: custom_taxonomy_term
label: Drupal 7 taxonomy terms
dependencies:
  enforced:
    module:
      - monster_migrate_7
migration_groups:
  - Drupal 7
source:
  plugin: custom_taxonomy_term
process:
  tid: tid
  vid:
    plugin: migration
    migration: custom_taxonomy_vocabulary
    source: vid
  name: name
  description: description
  weight: weight
  parent:
    -
      plugin: skip_on_empty  <--changed this per suggestion
      method: process
      source: parent
    -
      plugin: migration
      migration: custom_taxonomy_term
  changed: timestamp
destination:
  plugin: entity:taxonomy_term
migration_dependencies:
  required:
    - custom_taxonomy_vocabulary

And here's what I get when I try to execute it:

> drush migrate-manifest sites/all/modules/monster_migrate_7/manifest.yml --legacy-db-url=mysql://[user]:[pass]@localhost/monster
Running custom_taxonomy_vocabulary                                                                                                                                                    [ok]
Processed 0 items (0 created, 0 updated, 0 failed, 0 ignored) - done with 'custom_taxonomy_vocabulary'                                                                                [status]
Running custom_taxonomy_term                                                                                                                                                          [ok]
The "skip_process_on_empty" plugin does not exist.                                                                                                                                    [error]
> 
2

skip_process_on_empty and skip_row_on_empty were combined into a single plugin. Try this:

plugin: skip_on_empty
method: process

To skip a row:

plugin: skip_on_empty
method: row

Hope this helps!

  • Thanks for the response. Tried that and I'm still getting the error: The "skip_process_on_empty" plugin does not exist. but the process ends on it's own now but no imported terms (importing vocabulary worked fine). I don't get why it's still referring to "skip_process_on_empty" in the error. I tried drush cache-clear drush and drush cr to no avail. – Rooster242 Aug 26 '15 at 22:01
  • I updated the question with more info. – Rooster242 Aug 26 '15 at 22:17
  • 1
    Migrations are config entities. You can't just update the files in the module, you need to update them in your active configuration too. – Berdir Aug 26 '15 at 22:29
  • Not sure what you mean by that. Can you clarify? I'm still kind of a Drupal newb. – Rooster242 Aug 26 '15 at 23:15
  • Thanks Berdir, I caught up to you... I needed to reload the configuration with drush pm-uninstall [my_module] -y && drush en [my_module]. Also, Proxima's answer :) Thanks! – Rooster242 Aug 27 '15 at 1:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.