3

I have updated my CKEditor profiles to display the MediaEmbed button. The profile is saved, but when editing content, the button doesn't appear in my toolbar.
I'm using CKEditor 4.4, oEmbed plugin 1.17, jQuery 1.10 and the latest version of the CKEditor module.

Here's a screenshot of the config: CKEditor module

And another screenshot of the actual toolbar:
CKEditor toolbar

Any idea why?

1

I managed to resolve my problem but didn't have time to post it in here. It was simply misconfiguration...

First you need to install Widget, Lineutils and oEmbed plugins in CKEditor's plugin folder.
Then you need to specify the path to the plugins folder in CKEditor's module configuration.
Finally, in each of CKEditor's profile, you need to enable the plugins and move the oEmbed icon to the profile's toolbar.
Clear Drupal and browser cache and it should be working.

That's it!

0

All you have to do is: go to Configuration->Content Authoring->Ckeditor->click on Edit in Advanced or Full mode tick the check box of Plugin for embedding HTML snippets and that's it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.