0

It seems there are some problems with the content submission. When I select filtered HTML or full HTML, it shows a blank page after submitting a new node. I turned on the error messages, but I still get a blank page with no error message. When the input format is plain text, all works fine.

How do I resolve this issue?

  • 2
    Can you check your Apache error log ? It's generally located in /var/log/apache2/error.log ? – tostinni Dec 9 '11 at 23:42
  • 2
    some errors are can also often be written to watchdog table in DB, drush to the rescue: drush watchdog-show --tail will output error messages from that table to the console. – stefgosselin Dec 10 '11 at 0:18
  • 2
    php_error.log as well :) – Jimajamma Dec 10 '11 at 0:31
2

The White Screen of Death (or WSOD) can be caused by a lot of different things. There is an article about them http://drupal.org/node/158043

Without more information, especially error messages or logs, all answers will be guesses.

Follow the steps in the article above, in order and one by one, to track down your problem. The first step is making sure you can see errors by adding:

error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);

to you index.php or settings.php. Once you do this, you should see what is happening and be able to address it.

That said, the two biggest culprits of WSOD are errors in custom code and hitting the PHP memory limit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.