3

I've created translations files with poedit called nl_NL.mo and nl_NL.po and added them to a 'translations' folder within my custom module.

Now when I try to re-install my module; the translation isn't being imported.

Could this be because my default language is NL or is some other issue?

0

You might need to uninstall the module completely and reinstall it again, in order to be able to import the translations. Otherwise, they are not picked up automatically. There are a couple of threads in the Drupal forums mentioning this issue: https://www.drupal.org/node/220341 , https://www.drupal.org/node/435706#comment-2711736

Hope that helps,

  • I've disabled the module and after that de-installed it in the de-install module page, cleared the cache and re-installed with no result. – CaptainCarl Sep 3 '15 at 10:31
0

in

your_module.info.yml

you must indicate the file path

'interface translation project': your_module
'interface translation server pattern': modules/custom/your_module/translations/amu_hal-%language.po

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.