0

I would like to show a certain block only on one specific page. I want to use the Show block on specific pages feature for it. I have tried to set the url of my page like content/hills-restoration-process as well as the actual node number, like /node/36 but I don't seem to get it to work correctly. What am I doing wrong here? It seems like an easy and straight forward feature... Thanks for hints and suggestions!

  • What is happening? Is it showing on all pages or none? Or something different? – Darvanen Sep 4 '15 at 5:02
  • Please check all block settings like region, content type(Not restricted), Roles(Not restricted). – Akshay Sawant Sep 4 '15 at 7:46
1

When you use this field don't provide the leading slash. Try node/36.

Not sure why the alias wouldn't work - perhaps there's a character out of place. Node numbers work better because the block then doesn't disappear if the alias changes.

0

If this is a test site, first try making the block unrestricted.

If it does not appear, try assigning it to different content regions. If it appears in some but not others, this is probably a theming issue.

If it appears on every page as expected, you can then start applying your page restriction rule.

If this is a live site, follow the same approach but restrict the block to administrators until you have tracked down the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.