0

I'm using Drush 7 on Windows Server 2012 and IIS 8. Whenever I use drush up to update a third-party module, IIS can't access the files because during the update process, when drush is replacing the module files, the entire module folder contains permissions assigned to only the administrator, with inheritance disabled.

I need Drush to replace the module files with inheritance enabled; otherwise, Drupal will complain that it can't read the module files and break my site.

How can I achieve this?

4
  • What "inheritance" are we talking about here?
    – Clive
    Sep 7 '15 at 8:06
  • Inheritance in the sense that the new module files should inherit the permissions of the parent folder (i.e. the 'sites/all/modules' folder).
    – Strainy
    Sep 7 '15 at 8:57
  • Oh right, so file system permissions? Was there something about Drupal you needed to know?
    – Clive
    Sep 7 '15 at 9:03
  • Well specifically, how to either make drush conform to the file system permissions defined by the module folder or whether there's some sort of permissions option I've missed when setting up Drupal on my server that's causing this behavior.
    – Strainy
    Sep 7 '15 at 9:25
1

I know this is old but recently I stumble upon the same problem:

  • Site installed on IIS 8 under Windows Server 2012 R2

  • After updating with Drush core and modules, permissions of modules and updated files get messed up.

Solution I found is:

  • right click on website folder> Security > Advanced
  • check: "Replace all child object permission entries with inheritable permission entries from this object"
  • Apply

If files don't shows navigate to /sites/default/files or whenever files are stored and change permission to this folder and subfolders.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.