0

As title suggests my problem is missing tokens, at random intervals tokens will just cease to work on the site in question which makes any webform entries that are emailed out to a client appear empty. It also gets rid of all metatags from pages.

Metatag shows this while broken: These are not unused/disabled entries as the warning underneath suggests

Then if I catch it in a good mood after running drush rr: Note the Unknowns return and webforms begin working again

I am unable to see any errors in the database logs, no warnings/notices around the time of this happening either. Haven't got Entity Tokens enabled. The behaviour seems entirely random. I have read en earlier question with similar problems being caused by Node Export, I do not have this installed either.

Latest Drupal Core, latest Metatag, latest Webform versions. Infact everything is latest version as I ran a bunch of updates hoping that would fix the ongoing issue.

The URL Alias Patterns page is also empty, regardless of whether I have run drush rr and appeased the bug.

SimpleTest run on Token results in 0 fails 0 exceptions and a few debug messages that don't seem relevant.

Webform seems to be the culprit here, as it happens more often when I'm submitting webforms, though I'm not sure if it is. Version 4.1 of Webform.

Any help/ideas greatly appreciated

  • I don't know where to start ... I guess the obvious question is can you replicate this issue on a different server? Perhaps on a development machine with a more lenient mysql/php configuration. If it's the same issue on a completely different configuration then you can be sure it's something with your drupal code. Otherwise it might be run-environment related, or some caching software installed on your live servers going nuts. Could be anything. Sorry not much help – Beebee Sep 7 '15 at 22:06
  • Thanks I will try a copy on a local dev server, I agree this isn't much to go on its kind of a could be anything situation, just hoping someone has seen similar behaviour and knows where to look. It definetly seems triggered by Webform submissions. – Daniel Waters Sep 7 '15 at 22:41
  • i had a similar issue before but it was related to memcache module silently truncating caches that were larger than 1mb which ended up breaking views, after a cc all the views would come back for few minutes then go haywire again. I guess something like that's happening, but you can never be sure until you replicate the issue and isolate it. – Beebee Sep 7 '15 at 22:48
  • Hmm I run Zend Opcache but nothing else on that site beyond basic Drupal caching, I will check whether there's a possibility something like that is happening with the Opcache – Daniel Waters Sep 7 '15 at 22:50
  • opcache is probably not the culprit. Run your site on a dev machine, preferably without any caching software, and let us know what happens. – Beebee Sep 7 '15 at 22:53
0

We've run into this problem as well on a shared hosting production environment, as well as our staging environment. The first on PHP 5.5.9 with Zend OPcache v7.0.3, the latter with PHP 7.0.22 with Zend OPcache v7.0.22. In both environments some site un-deterministically "forgets" tokens. I debugged this down to function_exists() in the implementation of the hook system of Drupal. It seemed PHP just forget that modules implement the hook_info() functions.

A restart of PHP (PHP-FPM in these cases) fixes the problems, so my best guess is that the Zend OPcache is responsible for this erratic behavior. Note that the fact that environments are shared will probably increase the odds of this bug to surface.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.