0

I would like to have a page with some html content in it that CK Editor does not seem to support, in particular: I want to have a little <form tag with a couple of <input fields. I can enter it in Switch to plain text editor mode and save from there and it will keep the elements but when I want to edit the page, it'll go back to the Switch to rich text editor and remove my <form html items. How can i set CD Editor to not remove any html it may not be able to render? Thank you!

  • That's not a good way to do forms in Drupal. You should use the Webform module for drupal which has a nice admin interface and is more secure than what you're trying to do. – Beebee Sep 7 '15 at 22:55
  • @Beebee I'm using Webform already for my email and contact forms but this is a form with which I want to submit data to some other php script, not for emailing... – stdcerr Sep 7 '15 at 22:57
  • then you should get this addon module: Webform Remote Post which should fulfill your use case. – Beebee Sep 7 '15 at 23:00
2

Depending on which one you are using (filter or full html) You need to go to

/admin/config/content/formats/filtered_html

OR

/admin/config/content/formats/full_html

enter image description here

Then under Limit Allowed html Tags add <form> <input> into the list.

If that does not do it, try unchecking the correct faulty and chopped off html box.

Edit:

If you want to switch between text formats and not have your code erased go to:

/admin/config/content/ckeditor/edit/Advanced (for Filter HTML)

/admin/config/content/ckeditor/edit/Full (for Full HTML)

Then under Advanced Content Filter, select disabled.

enter image description here

  • Even when Correct faulty and chopped off HTML is unchecked, as soon as I hit Switch to rich text editor followed by Switch to plain text editor my form html gets removed. Also, there's no Limit allowed HTML tags as I'm using the Full HTML format – stdcerr Sep 7 '15 at 23:31
  • 1
    humm yes, switching does cause it to go blank. umm I guess you'll have to use the CKeditor "Source" button. – No Sssweat Sep 7 '15 at 23:44
  • 1
    nvm that doesn't work either. – No Sssweat Sep 7 '15 at 23:50
  • 1
    I think I found the solution, I edited my answer – No Sssweat Sep 8 '15 at 0:02
  • This is still a very bad practice to do forms this way through the text editor. – Beebee Sep 8 '15 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.