0

I have created a rule to trigger an email in user profile. But I could see the email after running cron only or else I could not see email in my inbox. Why is this? Can any one help in this please? I want to send an email automatically on particular date even though if I don't run the cron.

Can anyone help me? You will be appreciated.

enter image description here

  • please enhance your question for clear understanding. – WaQaR Ali Sep 8 '15 at 7:19
0

By programming theory anything is related to action, when anyone do any action then he get any result or response, in your theory I can not able to understand the action.

But I would like to suggest you by default every trigger works when cron runs, if you want to send mail without cron then set trigger on any action.

Enjoy!

  • Thank you, how to set trigger do we require any trigger module? – kashish Sep 8 '15 at 8:31
  • You need to install Rules module and enable trigger module which is core feature module,then you can easily create an action and trigger – user49660 Sep 8 '15 at 8:38
  • Its enabled, can u please suggest some tutorial to create an action and trigger the mail.because i am not familiar with rules. – kashish Sep 8 '15 at 8:41
  • Could you please tell me when you want to send the mail after which circumstances. – user49660 Sep 8 '15 at 8:45
  • after 11 months of creation user profile it has to send mail to user.well i have created the rules but its working only if we run the cron. – kashish Sep 8 '15 at 8:56
0

Are you by any chance using the SMTP module for your emails?

In its configuration ( admin/config/system/smtp ) there's a checkbox ( labelled "Send mail by queue" ) that has this exact behavior and it's a @&^% to debug, especially if you're not the one that did the initial installation.

  • yes i am using SMTP module – kashish Sep 8 '15 at 8:46
  • go to admin/config/system/smtp, uncheck the checkbox "Send mail by queue", save and retry. – Nick Andriopoulos Sep 8 '15 at 8:48
  • its uncheck only,please find the screen shot of it. – kashish Sep 8 '15 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.