0

Using Organic Groups, I'd like to have three visibility states:

  • Group and group content is visible to all, including anonymous users.

  • Authenticated users can see the group, but not the content.

    • This would be the same thing as if everyone marked all the content as "private", but the group node was marked as "public."
  • Only members of the group can see the group and the group content.

I tried OG Visibility, but it is no longer maintained and did not work. Or at least I couldn't figure out how to get it to work.

Any suggestions?

This is on Drupal 7.

1

Steps:

  1. Go to Configuration > Organic groups > OG field settings
  2. Under Bundle, select your group content type
  3. Under Fields, select Group visibility and click Add field
  4. Under Fields again, select Group content visibility and click Add field

Now these settings will add two fields into your group node which are Group visibility(Public or Private) and Group content visibility(Public or Private).

If I understood your comment requirements right, to achieve requirement:

  • No. 1 - Set group visibility to public and content visibility to public
  • No. 2 - Set group visibility to public and content visibility to private
  • No. 3 - Set group visibility to private and content visibility to private
  • That is pretty much what I'm doing now. What missing is that I want Public, Private, and Hidden as options where we currently have just Public and Private. That way users can just leave the visibility setting at the default when they create content. – David R. Sep 10 '15 at 19:35
  • Awesome! Hidden? How about using the node status as published or unpublished for it? – Leolando Tan Sep 11 '15 at 2:14
  • Hidden still needs to be visible to anyone in the group. Not sure how well using unpublished would work. Plus, my main goal is to make this really obvious to end users. That's why I'd like the three different options in the same place. I wonder if I should fork og_visibility... – David R. Sep 11 '15 at 21:42
  • So, OG Visibility decided to start working for me. Not sure why it wasn't working before. Plus, it's been a while since it started working... In any case, this answer is pretty much what people should do, so I'm checking it. – David R. Nov 5 '15 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.