1

I've installed gmap module and configured it so that I'm using custom markers. It worked well till today (I've re-deploy website).

I'm able to choose my custom marker 'Accountant' in a settings (see screen below). enter image description here

However when I load map I get an error message: "Request for invalid marker set" enter image description here

I've googled it and did not find a clear explanation what is wrong.

Please advise what could be an issue.

  • 1
    There are several results for this error. For example, did you try to follow advice given at drupal.org/node/2164713#comment-8526941? Also, it would be useful, if you could post any errors, that might appear in browser's console. – Miloš Kroulík Sep 10 '15 at 11:23
  • Hi Miloš Kroulík, thanks for that. I tried once and it did not work for me (later I realised it was due to access), so thank you! you were right, that was my case. – Dmytro Pastovenskyi Sep 11 '15 at 13:25
0

There is an update "REGENERATE MARKER CACHE" option in gmap settings.

enter image description here

By pressing "Regenerate" button Drupal will update JS file stored in

/sites/default/files/js

Make sure you have access to that file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.