1

I have a site with two languages (Dutch and English). However if I want to translate a Dutch node I must use the Dutch admin interface, and if I want to edit an English node I must use the English admin interface.

So let's say node/1 is in Dutch and node/2 is English, and my default language is Dutch. Now, if I go to /node/2/edit, so the edit form of the Enlish node in the Dutch language it redirects to /node/1/edit If I really must edit the English node I must go to /en/node/2/edit

Also the translated nodes are not present: enter image description here While I think it should also display which node ID's are the English and Dutch language on here. Like below: enter image description here The part in red is here like it should, but not on my production site as you can see in the first picture.

The second thing is that normally you can edit Dutch, Spanish, and English from the English admin pages. On my production site this I cannot do this. There I have to switch to the Spanish admin interface to translate to translate in Spanish, and I need to switch to English to translate to English.

What am I missing here.

  • Could you please make title a bit more precise? – Mołot Sep 10 '15 at 20:03
0

A possible explanation for your problem might be because of your "language detection" configuration.

Check this configuration via Configuration -> Languages -> detection and selection: the order should be 'URL, Default, User', and not something like 'Default, URL, User'.

  • The order is: 1. URL 2. Default And that is only because you cannot check off 'default'. – Noë Sep 10 '15 at 18:56
0

And sometimes it is good to have someone ask for clarification.

It appears to be the translation_overview module that is making it appear like this.

If I disable that module all works like it should.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.