1

I have defined a CCK field of the date type with an Hour granularity it looks like this:

screenshot

When I save it, it subtracts 2 hours from each one.

screenshot

I think it is caused from the set timezone.

My current timezone is "Europe/Madrid."

Mac-Pro:~ usuario1$ date
martes, 13 de diciembre de 2011, 17:33:23 CET

The server's timezone is the same.

Server:~ root$ date
mar dic 13 17:32:43 CET 2011

Why is Drupal doing this?

The dates have to be the same just as I type them.

1
  • If JimJamma's answer doesn't fix it, you may want to ask the question on the Ctools issue site at Drupal.org/project/ctools
    – Ashlar
    Commented Dec 13, 2011 at 21:23

1 Answer 1

3

In Drupal 6 at least, you would go to admin/settings/date-time to check the default timezone of Drupal. I'd check to see if that's set correctly. If it is, then you have to check if user configurable timezones are enabled, and if so, check what you or the logged in user has set in his/her account against all of the above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.