0

In my content I have one date field label, it is showing all uppercase letters automatically.

Example :I have given date field label as birthday(lower case) but it's automatically showing BIRTHDAY(UPPERCASE). How can I overcome this. enter image description here

enter image description here

  • Which Theme are you using? And what happens if you (temporary) switch to some other theme, eg one of the core themes? – Pierre.Vriens Sep 28 '15 at 11:07
  • @ Pierre.vriens - thanks for your response,i am using danland theme,and it is not temporary what i am doing. – DINE Sep 29 '15 at 5:13
  • The label your trying to modify comes under fieldset element. You are applying css property on wrong element. – WaQaR Ali Sep 29 '15 at 6:12
  • @ WaQaR Ali - Thanks for your response,Then what can i change,how can i over come this. – DINE Sep 29 '15 at 6:20
1

use Css if nothing is working to show the label in small letters.

text-transform: lowercase;
  • Comments have been removed; please don't use them for extended discussion. – kiamlaluno Sep 29 '15 at 9:31
1

According to my understanding you have applied CSS on wrong element, Please apply "text-transform: lowercase" on "label".

.from-type-textfield label {
           text-transform: lowercase
     } 

Please put it on your .css file it will work fine.

  • @ skv - Thanks for your response,from-type-textfield label { text-transform: lowercase } element is not there in my css file. – DINE Sep 29 '15 at 6:04
  • According to the Screen shot(Inspect Element) you provided initially there is <div class="from-type-textfield label..."> above date label, so take that class and put the .from-type-textfield label { text-transform: lowercase } as it is on your css file... it will work – Sujeet Kumar Verma Sep 29 '15 at 6:10
  • @SujeetKumarVerma you are applying css on wrong element. .from-type-textfield label is the class of simple textfield but the label of datefield as shown in above image comes under fieldset. – WaQaR Ali Sep 29 '15 at 6:16
0

As you are saying date field label is showing all uppercase letters automatically there might be the case of bad cache. to get rid of it do the following steps:

If you are working with command line try to clear the drupal cache by writing the command as:

 `drush cc all` 

If you are not using the command line then go in the Administer Settings: Configuration>>Development>> Performance or admin/config/development/performance and click on clear all cache. It should work fine.

and if not worked this too then apply the CSS code in the style.css file inside your theme folder for that particular element

text-transform: lowercase;
  • @ rfegade - Thanks for your response,how can i find date field element in css. – DINE Sep 29 '15 at 7:01
  • which browser are you using? if you are using firefox then install the add on named fire bug and then press F12 when you are on your website and inspect the particular all capital label of date field and check the class which is applied to it this all info is shown at the bottom when you start your fire bug tool, there you can edit the css also to alter the values. thanks – rfegade Sep 29 '15 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.