0

I am having some problems running drush site install through Puppet. When it comes for puppet to execute the following command I get an error. It appears as though the database URL is being truncated and then some non-verbose error tells me SQL cannot execute? If I try to install the site via the web-UI it works without any issues. I can connect from this machine using mysql client and the username/password.

[root@site:/var/www/html/drupal]#
#-> /usr/bin/php /var/webdeploy/src/composer/vendor/drush/drush/drush.php \
site-install -y -r /var/www/html/drupal \
--db-url=data.rds.awsdomain.com/dbname \
--db-su=user \
--db-su-pw=password \
--account-name=admin \
--account-pass=admin \
--account-mail=mail@example.com \
--site-name="site name" minimal

You are about to CREATE  the 'ata.rds.awsdomain.com/dbname' database. Do you want to continue? (y/n): y
Unable to generate CREATE DATABASE sql for                         [error]
No database to operate on.                                         [error]
1

Your --db-url is not in the correct format. Use this instead:

--db-url=mysql://USER@data.rds.awsdomain.com/dbname

Replace USER with the account used to access the database. If this is the same user that you have specified with --db-su, then the --db-su option is not necessary. Drush will not go the other way (fill in the "ordinary" user from the privileged user specified via --db-su), though.

  • Thanks - the URL format was the main problem. I did not user user:pass@ and kept the other options as-is. – gr4y Sep 30 '15 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.